It is currently Fri Sep 30, 2016 12:39 pm

All times are UTC - 6 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon Oct 24, 2005 11:44 am 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:55 pm
Posts: 48
Location: Fort Worth, Zone 8
I purchased this plant @ the GFWHS plant sale in May 2005 & planted it approx 1 wk later. It has spread well up a section of chain link, but except for the 4-7 blooms it had on it when I bought it, it has shown no desire to bloom since then. All the sites claim that it blooms til fall, either continuously or in successive flushes. I have fertilized w/ earthworm castings, kept the roots well mulched, & have seen NO sign of pests, yet the silly thing refuses to bloom. I've also tried stressing it slightly by cutting back on water, but it just sulks & droops til I give in. Any info appreciated. Also, can I dig it up to transplant, or am I better off trying to start new plants w/ cuttings, since I have no seeds. Thanks!

_________________
The kiss of the sun for pardon, the song of the birds for mirth, One is nearer God's Heart in a garden, than anywhere else on earth.
Dorothy F. Gurney, 1858-1932


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by eWeblife