It is currently Sat Aug 27, 2016 12:51 am

All times are UTC - 6 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Thu Jul 01, 2010 6:11 am 
Offline

Joined: Wed Jun 30, 2010 7:39 pm
Posts: 1
Hi,

I have a large, established Red Oak in the back yard (along with lots of Live Oaks). A couple of weeks ago a lot of the leaves started turning brown and dying.

One photo is attached below, and I've posted a small number of other photos that show the detail of what's happening here: http://picasaweb.google.com/110181772155578844823/Tree
(Click on individual photos to magnify them.)

Any diagnosis or recommendations?

Recent activity:
1) Dead wood (quite a few lower branches) were pruned in late April. Wounds were sprayed. The company that did the work says they sterilize their equipment, etc. (That's why I chose them!)

2) In early April I cleared the mulch under the tree, spread a layer of compost, tilled it into the soil by hand, put fertilizer stakes around the perimeter, and reapplied a layer of mulch.

Location: Austin, TX

Thanks!
Michael
Attachment:
P1040427.jpg
P1040427.jpg [ 130.06 KiB | Viewed 351 times ]


Top
 Profile  
 
PostPosted: Tue Jul 06, 2010 11:08 am 
Offline

Joined: Sun Mar 21, 2010 4:13 pm
Posts: 71
I have no idea. I hope it's not oak wilt. What are your typical irrigation habits? Have they changed? One that large should be relatively immune from heat problems.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 6 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by eWeblife